Community Discussion

Ask a Question

Server error validation campaign.inventory.error.server.urlNotAccessable

Hi, we are trying to update the URL of an ad and for some reason, we are getting the response campaign.inventory.error.server.urlNotAccessable with a message that the URL is not accessible, but we can open it and it is a valid public URL. Can we have some more information about what is the exact reason for the error? This, unfortunately, happens sometimes and it is not a constant thing.

"duplicate_settings" parameter not working in "Duplicate a Campaign" API

In replication settings the parameter duplicate_settings.include_blocked_publishers is not working. I duplicated a campaign using the duplicate_settings parameter and set include_blocked_publishers as False. The created campaign still has blocked publishers from the original campaign. On another campaign the parameter worked as expected Are there any conditions/factors that affect this parameter ? Please let me know if you need any more information
ANSWERED

Password Credentials Flow is broken

Hello Taboola Team Starting from today our clients cannot integrate their Taboola accounts using password credentials flow Credentials are correct User receives SMS code But: 1) api responds with 401 2) api doesn't mention anything about SMS 3) I don't see any announcements about this update Please clarify if this is a bug or expected behavior Also please let me know if you need any additional information Thanks, Igor
ANSWERED

Cannot set default platform_targeting

I am trying to set default platform targeting according to the documentation: https://developers.taboola.com/backstage-api/reference#campaign-platform-targeting "platform_targeting": { "type": "ALL", "value": [] } And the response is: { "http_status": 400, "message": "Cannot set platform_targeting type=ALL with value!=null", "offending_field": "platform_targeting", "message_code": "api.action.bad_request.platform_targeting" } Could you please clarify?
ANSWERED

City Targeting

Hi, I am unable to update city targeting.. I am trying to send the following update campaign request: Post: https://backstage.taboola.com/backstage/api/1.0/{account_id}/campaigns/8062238/ Body (Json): { "city_targeting": { "type": "INCLUDE", "value": [ "237319" ] } } and get the following respond: { "http_status": 404, "message": "account", "message_code": "api.action.resource_not_found" } What could be the problem? Thanks! Amir.
ANSWERED

Custom audience targeting update failure

Hello, I've been unsuccessfully trying to update the audience targeting of a campaign to make it include a custom audience. The steps I've taken follow: 1) I've successfully created a campaign through the Taboola API and set aside its id. 2) I've successfully created a new conversion through the Taboola UI. To be more specific: - I reached the "Tracking" section - I clicked "New Conversion" - I set the "Type" field as "Event", the "Based on" field as "Custom" and filled all the remaining fields. I managed to set aside its id extracting it from the created conversion page's URL. I know that this is not probably the proper way to accomplish the task, but was just meant as a temporary workaround while waiting for another question (https://developers.taboola.com/backstage-api/discuss/61d5df7ae026df01f3680a81) to be answered. 3) I've tried to update the targeting of the campaign by issuing a POST request to https://backstage.taboola.com/backstage/api/1.0/my_account_id/campaigns/the_campaign_id/targeting/custom_audience with this JSON body: { "collection": [{ "collection": [the_conversion_id], "type": "INCLUDE" }] } The API responds with an error: { "http_status": 400, "message": "Collection contains invalid rule ids for targeting: [1]", "offending_field": "custom_audience_targeting.collection[0].collection", "message_code": "campaign.unip.retargeting.rules.invalid.ids" } Am I doing something wrong? I supposed that creating a new custom conversion through the UI and creating a new custom audience rule through the API (https://developers.taboola.com/backstage-api/reference#create-a-custom-audience-rule) were interchangeable operations. Perhaps this is not the way it works but I could not make it clear reading the documentation and/or using the UI. Thanks is advance for your support.
ANSWERED

Difference of values in impression attribute from campaign summary report and top campaign content report

I'm not sure why, but the impression number from the Top Campaign Content Report does not match the impression number from the Campaign Summary Report. my campaign ID: 10730350 When I call the endpint: /api/1.0/audibene-fr-sc/reports/campaign-summary/dimensions/campaign_breakdown/?start_date=2021-06-01&end_date=2021-06-01 The response is: [ { "campaign": "10730350", "impressions": 277475, ... }, ... ] And when I call this endpoint: /api/1.0/audibene-fr-sc/reports/top-campaign-content/dimensions/item_breakdown/?start_date=2021-06-01&end_date=2021-06-01&campaign=10730350 The response is: [ { "impressions": 142764, ... }, { "impressions": 75512, ... }, { "impressions": 59172, ... }, ] When I aggregate up the item impressions, the result is 277448, which differs from 277475 (the figure I obtained from the previews endpoint), thus I'm not sure why the disparity exists or which number I should consider.

Video Campaign Summary API is not working , showing error Requested action is forbidden

Failing conversion rule creation

Hello. I've been recently trying to create a conversion rule through the Taboola Backstage API, as specified in the appropriate section of the documentation (https://developers.taboola.com/backstage-api/reference#create-a-conversion-rule). In order to create the rule, I've been issuing a POST request to the following endpoint, https://backstage.taboola.com/backstage/api/1.0/{my_account_id}/universal_pixel/conversion_rule/ with a correctly generated Access Token (I've been using it to call several other API endpoints as well and it worked in those circumstances). My JSON body is: { "event_name": "test_pixel", "display_name": "test_pixel", "include_in_total_conversions": false, "category": "SEARCH", "status": "ACTIVE", "type": "EVENT_BASED", "condition": [], "exclude_from_campaigns": false, "look_back_window": 30 } Even though there seems to be no inconsistency with the documentation (all fields seems to be correctly configured and no required field is missing, apparently), the API responds with an error: { "http_status": 400, "message": "Bad request", "message_code": "api.action.bad_request.null" } No meaningful message is associated with the response and I don't know how to make this work. Thanks in advance for your support.
ANSWERED

by_referral_and_tracking_code URL - {'http_status': 403, 'message': 'Requested action is forbidden', 'message_code': 'api.action.forbidden'}

I create a new post since this post (https://developers.taboola.com/backstage-api/discuss/6194042cca3ee0001e529506 ) was marked as answered. I reached out to my account manager and we sorted out which users and api credentials to use. He said to reach out and ask to give [email protected] access to be able to access the following: params = {'start_date': '2022-01-03', 'end_date': '2022-01-03'} header = {'Authorization': 'Bearer {token}'} URL = https://backstage.taboola.com/backstage/api/1.0/reachmobi-mindyourdollars-slideshow/reports/visit-value/dimensions/by_referral_and_tracking_code?
150030003014004014034044294_flows50050390_daysaccess_tokenaccountaccount_creationaccount_idaccount_levelaccount_level_blockaccount_typeaccountsactivity_scheduleactual_cpcadvertiser_idadvertisersallowed_accountsalphabeticapi_accessapi_changesapi_keyapi_newsletterapi_secretaudienceaudience_onboardingaudience_segmentsaudience_targetingaudiencesaudit_trailauthorization_codeauto_targetingaws_downtimeaws_serverbalancebasebasic_authenticationbibidbid_modifierbid_modifiersbillingbilling_cycleblockblock_publisherblock_publishersbrand_safetybrowser_breakdownbulk_createbulk_updatebulk_update_campaignsby_audienceby_campaignby_hour_of_daycachingcampaigncampaign_daycampaign_day_breakdowncampaign_fieldscampaign_learningcampaign_levelcampaign_ownercampaign_site_daycampaign_summarycampaignscity_targetingclick_idclicksclient_credentialscode_snippetconnectorcontent-typeconversion_dataconversion_ruleconversionsconversions_valuecorscountriescountrycountry_codescpa_actionscpa_actions_numcpccpc_macrocreate_campaigncreate_itemcreate_timecreation_datecustom_audiencecustom_audience_rulecustom_conversion_rulecustom_conversionscut_offdaily_capdaily_spenddata_freshnessdata_studiodata_studio_connectordayday_dimensiondelaydeletedictionarydifferent_accountdiscrepancydocs_issuedocumentationdomainduplicateduplicate_campaignempty_responseend_dateevent_basedexelatefeature_requestfetch_levelfiltersfirst_party_audienceflowfull_authenticationget_account_detailsgoogle_apps_scriptgoogle_scriptgoogle_sheetshidden_audiencehidden_segmentshourlyhourly_reportinghourly_spendhtmlhtml_login_pagehtml_responseiasimplicit_flowinactive_accountsinclude_multi_conversionsinclusionsintegrationinternal_support_ticketip_addressis_atomicitemitemsixudra_curljava_client_sdkjava_sdkjavascriptjsjupyter_notebooklaravellearning_statelimitlist_of_publisherslookalike_audiencelookalike_audienceslookback_windowloss_of_scalemacrosmalformed_jsonmarketplacemarketplace_audiencesmax_campaignsmax_itemsmax_resultsminimum_bidminimum_cpcmixedanalyticsmy_audiencesnetworknetwork_accountnew_featurenullnumeric_site_idoauth2os_breakdownpage_viewpagingpartner_typepassword_credentialspatchpausepermissionsphppixel_lookalikeplacementplacement_breakdownplacement_filterplacement_nameplatform_targetingpostmanprecannedprerequisites_not_metpublisherpublisher_bid_modifierpublisher_blockspublisher_idpublisher_namepublisher_networkpublisher_reportspublisher_targetingpublisher_urlpublisherspythonpython_clientrrate_limitreal_timereal_time_reportingrecommendation_apiredirect_urirejected_campaignsremove_allreport_cachingreportingreporting_discrepancyreportsretention_periodrevenuerevenue_summaryrevenue_summary_reportroadmaps2ssafety_ratingsalessandboxscalesitesite_breakdownsite_nameslowslownesssort_filterspecial_charsspendspending_limitsslssostatussub_accountssupermetricssupport_tickettataboola_adstaboola_pixeltargetingtcctest_accounttheoptimizertimeouttimezonetlstop_campaign_contenttop_contenttracking_codetypouiunblock_publishersunknown_publisherupdate_itemupload_imageurluser_accountsuser_segmentsutmvaluevideovideo_campaign_summaryvideo_campaignsvideo_completionsvideo_itemvideo_itemsviewsvisit_valuevoluumweb_hookswhitelistx-www-form-urlencodedyearly_reportingנ